Managing DynamoDB tables in Terraform when onboarding to Clumio

If you manage DynamoDB resources with Terraform. Clumio will need the usage of one reader from a DynamoDB stream.

Symptoms

Backups fail with error messages stating: [Backup chain found for the DynamoDB table [TABLE_NAME]. Attempting incremental table backup], and streams being constantly being disabled/re-enabled. This is highly likely due to DynamoDB streams not being enabled in AWS.

Root cause

The issue stems from managing DynamoDB tables in Terraform and Streams not enabled with a compatible view type. Clumio supports view types [โ€œNEW_IMAGEโ€, and โ€NEW_AND_OLD_IMAGESโ€]. To achieve the best performance for Clumio related backups, select NEW_IMAGE.

If there are any questions or concerns for Clumio to use a reader on DynamoDB streams, contact support.

Resolution

If you encounter DynamoDB failures related to a broken backup chain and your DynamoDB tables that are managed via Terraform do not have streams enabled. Make the following configurations to your DynamoDB resource in Terraform. [AWS provider link]

resource "aws_dynamodb_table" "example" {
...
    stream_enabled              = true
    stream_view_type            = "NEW_IMAGE"
...
}


Contact support with any questions or concerns.