Error: Backups Failing Due To AWS Snapshot Quota

Symptoms

EC2 and/or RDS backups fail in the AWS environment with the following error message:

Quota exceeded: Failed to take a snapshot

Root Cause

AWS has a soft limit on the number of snapshots that can be in an account's inventory per region. Clumio leverages AWS snapshots to perform backups for RDS/EC2 entities. The latest snapshot copy of every protected asset is retained in your AWS account's inventory to calculate the delta in order to perform incremental backups. If you notice the snapshots in your AWS accounts are increasing and your backups with Clumio are failing, then you might be hitting the following snapshot limits:

Resolution

If you are encountering failed backups due to AWS quota limitations, perform the following steps to resolve this issue:

  1. Open the AWS Service Quotas dashboard.
  2. Choose the Amazon Resource that you wish to select.
  3. Choose the required service quota.
  4. Choose request quota increase.
  5. Once you have confirmed that your quota for your AWS account has increased, you can notify Clumio support.

Please contact [email protected] for clarifications or questions.