Error: Clumio RDS restore to new AWS account failing with an "Internal Error"

Symptoms

Attempting to restore an RDS rolling backup copy to a new AWS account/region with no prior RDS Instances deployed fails with an "Internal Error". 

Root Cause

The RDS rolling backup restores require the RDS service components like VPC, Service Linked Role, Parameter Groups, Subnet Groups, etc. to be present in the account before the restore is performed. Clumio restores workflow is based on the security first principle and is restricted to perform privileged actions like creating/deleting the prime RDS services. As a result, restores performed in an account without the mentioned services being available will run into a failure.  

Resolution

If you are encountering an RDS restore failure while restoring a rolling backup to a new AWS account, go through the steps mentioned below before triggering a restore task from the Clumio portal:

  • Log in to the AWS account to which the restore needs to be performed.
  • Select the correct region and go to the RDS Service console.
  • Create a new RDS Instance/Cluster in this account/region with the required details. This will ensure that all the prime RDS services are configured for this AWS account.
  • Once the RDS Instance/Cluster is successfully created, it can be deleted from the AWS Account.
  • You can now go ahead and trigger the RDS restore task from the Clumio console and expect it to go through without any issues.

For any additional questions, please reach out to [email protected]